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[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

SYMPTOMS

When you run or refresh a report you get the following message:
[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified.

CAUSE

This behavior occurs when the system data source name (DSN) you specified in the report does not exist. This message most often appears when you mistype the DSN name in the system DSN properties.

RESOLUTION

To resolve this behavior, use one of the following methods:

Method 1: If you have not yet set up your system DSN

If you have not set up your system DSN, you must set it up. To do this, follow these steps:
1. On the Windows Start menu, point to Settings, and then click Control Panel.
2. Double-click the 32bit ODBC icon (Windows 95) or the ODBC icon (Windows NT).
3. Click the System DSN tab.
4. Click Add.
5. Select the driver you want to use. For example, select "Microsoft Access Driver (*.mdb)." Click Finish.
6. In the Data Source Name box, type the name you specified in the Database Region Wizard.
NOTE: The DSN name should not include any spaces.
7. Click Select.
8. Select the database file you want to use.
9. Click OK three times.

Method 2: If you have already set up your system DSN

If you have already set up your system DSN, you must verify the name of the DSN and specify the DSN name in the database region. To do this, follow these steps:
1. On the Windows Start menu, point to Settings, and then click Control Panel.
2. Double-click the 32bit ODBC icon (Windows 95) or the ODBC icon (Windows NT).
3. Click the System DSN tab.
4. Note the name of your system DSN.
5. Right-click any of the database column values and then click Database Region Properties on the menu that appears.
6. Click Back.
7. Type the name of the system DSN you noted in step 4 and then click Finish.




 

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